首页
JAVA笔记
数据库笔记
混乱记忆
小站记
您现在的位置
android android-support-v4 v7 v8 v13 v17 的特性说明
简介: 本指南说明了支持库提供了重要的功能和版本的支持,以帮助你决定哪些人你应该在你的应用程序。一般情况下,我们建议包括V4支持和V7 appcompat库,因为它们支持广泛的Android的版本,并提供API来推荐用户界面模式。
V4支持库
应用组件
片段 -增加了对用户界面和功能与片段的封装支持,使应用程序能够提供小型和大屏幕设备之间的调整布局。
NotificationCompat -添加丰富的通知功能的支持。
LocalBroadcastManager -允许应用程序轻松注册,并在一个单一的应用程序接收的意图,而不在全球播放它们。
用户界面
ViewPager -添加 的ViewGroup,管理布局为孩子的意见,这对用户之间可以刷卡。
PagerTitleStrip -增加一个非交互标题条,可以被添加作为一个子 ViewPager。
PagerTabStrip -增加一个导航部件分页视图之间进行切换,即也可以与使用 ViewPager。
DrawerLayout -用于创建添加支持导航抽屉,可以从一个窗口的边缘被拉到中。
SlidingPaneLayout -用于创建链接的摘要和详细视图,适当地适应各种屏幕尺寸添加小部件。
可访问性
ExploreByTouchHelper -增加了一个辅助类实现了自定义视图可访问性支持。
AccessibilityEventCompat -为增加支持 AccessibilityEvent。有关实现可访问性的更多信息,请参阅辅助功能。
AccessibilityNodeInfoCompat -为增加支持AccessibilityNodeInfo。
AccessibilityNodeProviderCompat -为增加支持AccessibilityNodeProvider。
AccessibilityDelegateCompat -为增加支持 View.AccessibilityDelegate。
内容
装载机 -增加了对数据的异步加载的支持。该库还提供了此类的具体实现,包括 CursorLoader和 AsyncTaskLoader。
FileProvider -添加应用程序之间共享私人文件的支持。
有包括在这个库中许多其他的API。有关V4支持库API的完整,详细的信息,请参阅android.support.v4包中的API参考。

该库位于<SDK> /演员/安卓/支持/ V4 /目录中下载Android支持库后。该库中不包含用户界面资源。把它列入你的应用程序项目,然后按照说明 添加库没有资源。

这图书馆的摇篮构建脚本依赖标识符如下:

COM 。机器人。支持:支持- V4 :21.0 +
这种依赖性符号指定发行版本21.0.0或更高版本。

Multidex支持库
该库提供了多的Dalvik可执行文件(DEX)文件构建应用程序的支持。引用超过65536方法的应用程序都需要使用multidex配置。有关使用multidex的详细信息,请参阅 

构建应用程序与在65K方法。

该库位于<SDK> /演员/安卓/支持/ multidex /目录中下载Android支持库后。该库中不包含用户界面资源。把它列入你的应用程序项目,然后按照说明添加库没有资源


这图书馆的摇篮构建脚本依赖标识符如下:

COM 。机器人。支持:multidex :1.0 。+
这种依赖性符号指定发行版本1.0.0或更高版本。

V7支持库
有设计成与Android 2.1(API 7级)和较高的使用几个库。这些图书馆提供特定的功能集,并可以包含在独立的应用程序彼此。

V7 appcompat库

这个库增加了对支持 操作栏的用户界面设计模式。该库包括支持 材料设计的用户界面实现。

注意: 这个库依赖于V4支持库。如果您在使用Ant或者Eclipse,请确保您包括V4支持库,因为这个库的类路径中的一部分。

这里有几个关键的类包含在V7 appcompat库:

动作条 -提供的操作栏的实现 用户界面模式。有关使用操作栏的详细信息,请参阅 操作栏开发人员指南。
ActionBarActivity -添加时必须使用作为活动使用的支持库操作栏实现基类的应用程序活动课。
ShareActionProvider -一个标准化的分享动作(如电子邮件,或张贴到社交应用),可以包含在动作条上增加了支持。
该库位于<SDK> /演员/安卓/支持/ V7 / appcompat / 目录中下载Android支持库后。该库包含用户界面资源。把它列入你的应用程序项目,然后按照说明 添加库的资

源。

这图书馆的摇篮构建脚本依赖标识符如下:

COM 。机器人。支持:appcompat - V7 :21.0 +
这种依赖性符号指定发行版本21.0.0或更高版本。

V7 cardview库

这个库增加了对支持CardView 控件,它可以让你证明这里面有一个一致的外观上的任何应用程序卡的信息。这些卡是材料设计的实现是有用的,并且被广泛用于布局的

电视应用程序。

该库位于 <SDK> /演员/安卓/支持/ V7 / cardview /目录中下载Android支持库后。该库包含用户界面资源。把它列入你的应用程序项目,然后按照说明添加库的资源


这图书馆的摇篮构建脚本依赖标识符如下:

COM 。机器人。支持:cardview - V7 :21.0 +
这种依赖性符号指定发行版本21.0.0或更高版本。

V7 GridLayout的图书馆

这个库增加了对支持GridLayout的类,它允许你安排使用矩形单元的网格用户界面元素。有关V7 GridLayout的库API的详细信息,请参阅 android.support.v7.widget

包中的API参考。

该库位于<SDK> /演员/安卓/支持/ V7 / GridLayout的/ 目录中下载Android支持库后。该库包含用户界面资源。把它列入你的应用程序项目,然后按照说明 添加库的

资源。

这图书馆的摇篮构建脚本依赖标识符如下:

COM 。机器人。支持:GridLayout的- V7 :21.0 +
这种依赖性符号指定发行版本21.0.0或更高版本。

V7 mediarouter库

该库提供MediaRouter,MediaRouteProvider,以及相关的媒体类,支持谷歌演员。

在一般情况下,在第7版mediarouter库中的API提供的控制的媒体信道的路由的一种方法,并从当前设备到外部屏幕,扬声器,和其他的目的设备流。该库包含的API用

于发布应用程序特定的媒体路由提供商,为发现和选择目标设备,用于检查介质的状态,等等。有关V7 mediarouter库API的详细信息,请参阅 

android.support.v7.media包中的API参考。

mediarouter库位于该V7 <SDK> /演员/安卓/支持/ V7 / mediarouter /目录中下载Android支持库后。它作为一个库项目,在V7 appcompat库的依赖性,所以你需要设

置,当你的项目,包括图书馆在构建路径。有关如何设置你的项目的更多信息,请按照说明添加库的资源。如果您正在开发在Eclipse / ADT,请务必同时包含Android

的支持-V7-mediarouter.jar和 Android的支持-V7-appcompat.jar文件。

如果您使用的是Android的工作室,所有你需要做的是指定的摇篮构建脚本的依赖标识符com.android.support:support-v7-mediarouter:<修订>,其中“<修订>”是最

低版本在该图书馆是可用的。例如:

COM 。机器人。支持:mediarouter - V7 :21.0 +
在支持库R18推出的V7 mediarouter库API都受到了支持库的更新版本改变。这时,我们建议您使用该库仅在连接谷歌演员。

V7调色板库

在V7调色板支持库包括 面板类,它可以让你从图像中提取突出的颜色。例如,一个音乐应用程序可以使用一个 调色板对象从专辑封面中提取的主要颜色,并用这些颜

色来打造一个色彩协调的歌名卡。

该库位于 <SDK> /演员/安卓/支持/ V7 /调色板/目录中下载Android支持库后。该库中不包含用户界面资源。把它列入你的应用程序项目,然后按照说明 添加库没有资

源。

这图书馆的摇篮构建脚本依赖标识符如下:

COM 。机器人。支持:调色板- V7 :21.0 +
这种依赖性符号指定发行版本21.0.0或更高版本。

V7 recyclerview库

该recyclerview库添加RecyclerView 类。该类提供用于支持 RecyclerView插件,用于通过提供的数据项的有限窗口有效地显示大量数据集的图。

该库位于 <SDK> /演员/安卓/支持/ V7 / recyclerview /目录中下载Android支持库后。该库包含用户界面资源。把它列入你的应用程序项目,然后按照说明添加库的

资源。

这图书馆的摇篮构建脚本依赖标识符如下:

COM 。机器人。支持:recyclerview - V7 :21.0 +
这种依赖性符号指定发行版本21.0.0或更高版本。

V8支持库
这个库被设计成与Android(API等级8)和较高的使用。它增加了对支持RenderScript计算框架。这些API包括在android.support.v8.renderscript包。你应该知道的步

骤,包括这些API在应用程序中是非常不同的其他的支持库API。有关在应用程序中使用这些API的更多信息,请参阅 RenderScript 开发人员指南。

注:使用RenderScript与支持库支持与Android的Eclipse插件和Ant构建工具。它是目前不采用Android Studio或支持的摇篮-基于构建。

V13支持库
这个库是设计用来为Android 3.2(API级别13)和更高。它增加了对支持片段的(用户界面模式FragmentCompat)类和附加片段支持类。有关片段的详细信息,请参阅 

碎片开发人员指南。有关V13支持库API的详细信息,请参阅android.support.v13包中的API参考。

该库位于<SDK> /演员/安卓/支持/ V13 /目录中下载Android支持库后。该库中不包含用户界面资源。把它列入你的应用程序项目,然后按照说明 添加库没有资源。

这图书馆的摇篮构建脚本依赖标识符如下:

COM 。机器人。支持:支持- V13 :18.0 +
这种依赖性符号指定发行版本18.0.0或更高版本。

V17尽兴赏图书馆
该android.support.v17.leanback包提供的API来支持建筑物的用户界面在电视上的设备。它提供了许多重要的窗口小部件用于电视的应用程序。一些著名的类包括:

BrowseFragment -的片段,用于创建一个主布局为浏览类别和行的媒体项目。
DetailsFragment -一个包装片段Leanback的细节画面。
PlaybackOverlayFragment -的一个子类DetailsFragment用于显示播放控制及相关内容。
SearchFragment -一个片段来处理搜索。片段接收到用户的搜索请求,并把它传递给应用程序提供的SearchResultProvider。该SearchResultProvider返回搜索结果给 

SearchFragment,这使得它们成为一个RowsFragment。
该库位于 <SDK> /演员/安卓/支持/ V17 / Leanback的目录中下载Android的支持库后。有关如何设置你的项目的更多信息,请按照说明添加库的资源。

这图书馆的摇篮构建脚本依赖标识符如下:

COM 。机器人。支持:轻松看- V17 :21.0 +
这种依赖性符号指定发行版本21.0.0或更高版本。
本文内容来自 google 翻译
最近更新